求調和級數前n項和(Harmonic Number )


 

知識點:

調和級數(即f(n))至今沒有一個完全正確的公式,但歐拉給出過一個近似公式:(n很大時)

f(n)≈ln(n)+C+1/2*n

歐拉常數值:C≈0.57721566490153286060651209

In mathematics, the nth harmonic number is the sum of the reciprocals of the first n natural numbers:

 

 

In this problem, you are given n, you have to find Hn.

Input

Input starts with an integer T (≤ 10000), denoting the number of test cases.

Each case starts with a line containing an integer n (1 ≤ n ≤ 108).

Output

For each case, print the case number and the nth harmonic number. Errors less than 10-8 will be ignored.

Sample Input

12

1

2

3

4

5

6

7

8

9

90000000

99999999

100000000

Sample Output

Case 1: 1

Case 2: 1.5

Case 3: 1.8333333333

Case 4: 2.0833333333

Case 5: 2.2833333333

Case 6: 2.450

Case 7: 2.5928571429

Case 8: 2.7178571429

Case 9: 2.8289682540

Case 10: 18.8925358988

Case 11: 18.9978964039

Case 12: 18.9978964139

#include <map>
#include <stack>
#include <queue>
#include <cmath>
#include <vector>
#include <cstdio>
#include <cstring>
#include <iostream>
#include <algorithm>
#define ll long long

using  namespace std;

const double r=0.57721566490153286060651209;

double a[10004];

int main()
{
    a[1]=1;
    for(int i=2;i<=10000;i++)
    {
        a[i]=a[i-1]+1.0/i;
    }
    int T,n;
    scanf("%d",&T);
    for(int k=1;k<=T;k++)
    {
        scanf("%d",&n);
        if(n<=10000)
        {
            printf("Case %d: %.10lf\n",k,a[n]);
        }
        else
        {
            double ans=log(n)+r+1.0/(2*n);
            printf("Case %d: %.10lf\n",k,ans);
        }
    }
    return 0;
}
View Code


免責聲明!

本站轉載的文章為個人學習借鑒使用,本站對版權不負任何法律責任。如果侵犯了您的隱私權益,請聯系本站郵箱yoyou2525@163.com刪除。



 
粵ICP備18138465號   © 2018-2025 CODEPRJ.COM