POJ1679 The Unique MST(Kruskal)(最小生成樹的唯一性)


The Unique MST
Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 27141   Accepted: 9712

Description

Given a connected undirected graph, tell if its minimum spanning tree is unique.

Definition 1 (Spanning Tree): Consider a connected, undirected graph G = (V, E). A spanning tree of G is a subgraph of G, say T = (V', E'), with the following properties:
1. V' = V.
2. T is connected and acyclic.

Definition 2 (Minimum Spanning Tree): Consider an edge-weighted, connected, undirected graph G = (V, E). The minimum spanning tree T = (V, E') of G is the spanning tree that has the smallest total cost. The total cost of T means the sum of the weights on all the edges in E'.

Input

The first line contains a single integer t (1 <= t <= 20), the number of test cases. Each case represents a graph. It begins with a line containing two integers n and m (1 <= n <= 100), the number of nodes and edges. Each of the following m lines contains a triple (xi, yi, wi), indicating that xi and yi are connected by an edge with weight = wi. For any two nodes, there is at most one edge connecting them.

Output

For each input, if the MST is unique, print the total cost of it, or otherwise print the string 'Not Unique!'.

Sample Input

2
3 3
1 2 1
2 3 2
3 1 3
4 4
1 2 2
2 3 2
3 4 2
4 1 2

Sample Output

3
Not Unique!
【分析】最小生成樹的唯一性,思路是先判斷每條邊是否有重邊,有的話eq=1,否則0.然后第一次求出最小生成樹,將結果記錄下來,
然后依次去掉第一次使用過的且含有重邊的邊,再求一次最小生成樹,若結果與第一次結果一樣,則不唯一。
#include <iostream>
#include <cstdio>
#include <cstdlib>
#include <cmath>
#include <algorithm>
#include <climits>
#include <cstring>
#include <string>
#include <set>
#include <map>
#include <queue>
#include <stack>
#include <vector>
#include <list>
#include<functional>
#define mod 1000000007
#define inf 0x3f3f3f3f
#define pi acos(-1.0)
using namespace std;
typedef long long ll;
const int N=11000;
const int M=15005;
int n,m,cnt;
int parent[N];
bool flag;
struct man {
    int u,v,w;
    int eq,used,del;
} edg[N];
bool cmp(man g,man h) {
return g.w<h.w;
}
void init() {
    for(int i=0; i<=10005; i++) {
        parent[i]=i;
    }
}
int Find(int x) {
    if(parent[x] != x) parent[x] = Find(parent[x]);
    return parent[x];
}//查找並返回節點x所屬集合的根節點
void Union(int x,int y) {
    x = Find(x);
    y = Find(y);
    if(x == y) return;
    parent[y] = x;
}//將兩個不同集合的元素進行合並
int Kruskal() {
    init();
   int sum=0;
   int num=0;
   for(int i=0;i<m;i++){
    if(edg[i].del==1)continue;
    int u=edg[i].u;int v=edg[i].v;int w=edg[i].w;

    if(Find(u)!=Find(v)){
        sum+=w;
        if(!flag)edg[i].used=1;
        num++;
        Union(u,v);
    }
    if(num>=n-1)break;
   }
   return sum;
}
int main() {
    int t,d;
    cin>>t;
    while(t--) {
        cnt=0;
        cin>>n>>m;
        for(int i=0; i<m; i++) {
            cin>>edg[i].u>>edg[i].v>>edg[i].w;
            edg[i].del=0;
            edg[i].used=0;
            edg[i].eq=0;//一開始這個地方eq沒有初始化,WA了好幾發,操
        }
        for(int i=0;i<m;i++){
            for(int j=0;j<m;j++){
                if(i==j)continue;
                if(edg[i].w==edg[j].w)edg[i].eq=1;
            }
        }
        sort(edg,edg+m,cmp);
        flag=false;
        cnt=Kruskal();
        flag=true;
        bool gg=false;
        for(int i=0;i<m;i++){
            if(edg[i].used==1&&edg[i].eq==1){
                edg[i].del=1;
                int s=Kruskal();//printf("%d %d\n",i,s);
                if(s==cnt){
                    gg=true;
                    printf("Not Unique!\n");
                    break;
                }
                edg[i].del=0;
            }
        }
        if(!gg)cout<<cnt<<endl;
    }
    return 0;
}
View Code


免責聲明!

本站轉載的文章為個人學習借鑒使用,本站對版權不負任何法律責任。如果侵犯了您的隱私權益,請聯系本站郵箱yoyou2525@163.com刪除。



 
粵ICP備18138465號   © 2018-2025 CODEPRJ.COM