Train Problem II
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 2830 Accepted Submission(s): 1562
Problem Description
As we all know the Train Problem I, the boss of the Ignatius Train Station want to know if all the trains come in strict-increasing order, how many orders that all the trains can get out of the railway.
Input
The input contains several test cases. Each test cases consists of a number N(1<=N<=100). The input is terminated by the end of file.
Output
For each test case, you should output how many ways that all the trains can get out of the railway.
Sample Input
1 2 3 10
Sample Output
1 2 5 16796
Hint
The result will be very large, so you may not process it by 32-bit integers.
Author
Ignatius.L
簡單的卡特蘭數問題。
卡特蘭數介紹:
這個已經可以做為模版了~~~
//h( n ) = ( ( 4*n-2 )/( n+1 )*h( n-1 ) );
#include<stdio.h>
//*******************************
//打表卡特蘭數
//第 n個 卡特蘭數存在a[n]中,a[n][0]表示長度;
//注意數是倒着存的,個位是 a[n][1] 輸出時注意倒過來。
//*********************************
int a[105][100];
void ktl()
{
int i,j,yu,len;
a[2][0]=1;
a[2][1]=2;
a[1][0]=1;
a[1][1]=1;
len=1;
for(i=3;i<101;i++)
{
yu=0;
for(j=1;j<=len;j++)
{
int t=(a[i-1][j])*(4*i-2)+yu;
yu=t/10;
a[i][j]=t%10;
}
while(yu)
{
a[i][++len]=yu%10;
yu/=10;
}
for(j=len;j>=1;j--)
{
int t=a[i][j]+yu*10;
a[i][j]=t/(i+1);
yu = t%(i+1);
}
while(!a[i][len])
{
len--;
}
a[i][0]=len;
}
}
int main()
{
ktl();
int n;
while(scanf("%d",&n)!=EOF)
{
for(int i=a[n][0];i>0;i--)
{
printf("%d",a[n][i]);
}
puts("");
}
return 0;
}