poj-3253-Fence Repair(哈夫曼)


/*
Fence Repair
Time Limit: 2000MS        Memory Limit: 65536K
Total Submissions: 19914        Accepted: 6314
Description

Farmer John wants to repair a small length of the fence around the pasture. He measures the fence and finds that he needs N (1 ≤ N ≤ 20,000) planks of wood, each having some integer length Li (1 ≤ Li ≤ 50,000) units. He then purchases a single long board just long enough to saw into the N planks (i.e., whose length is the sum of the lengths Li). FJ is ignoring the "kerf", the extra length lost to sawdust when a sawcut is made; you should ignore it, too.

FJ sadly realizes that he doesn't own a saw with which to cut the wood, so he mosies over to Farmer Don's Farm with this long board and politely asks if he may borrow a saw.

Farmer Don, a closet capitalist, doesn't lend FJ a saw but instead offers to charge Farmer John for each of the N-1 cuts in the plank. The charge to cut a piece of wood is exactly equal to its length. Cutting a plank of length 21 costs 21 cents.

Farmer Don then lets Farmer John decide the order and locations to cut the plank. Help Farmer John determine the minimum amount of money he can spend to create the N planks. FJ knows that he can cut the board in various different orders which will result in different charges since the resulting intermediate planks are of different lengths.

Input

Line 1: One integer N, the number of planks 
Lines 2..N+1: Each line contains a single integer describing the length of a needed plank
Output

Line 1: One integer: the minimum amount of money he must spend to make N-1 cuts
Sample Input

3
8
5
8
Sample Output

34
Hint

He wants to cut a board of length 21 into pieces of lengths 8, 5, and 8. 
The original board measures 8+5+8=21. The first cut will cost 21, and should be used to cut the board into pieces measuring 13 and 8. The second cut will cost 13, and should be used to cut the 13 into 8 and 5. This would cost 21+13=34. If the 21 was cut into 16 and 5 instead, the second cut would cost 16 for a total of 37 (which is more than 34).
Source

USACO 2006 November Gold

題目大意:FJ需要修補牧場的圍欄,他需要 N 塊長度為 Li 的木頭(N planks of woods)。開始時,FJ只有一塊無限長的木板,因此他需要把無限長的木板鋸成 N 塊長度

為 Li 的木板,Farmer Don提供FJ鋸子,但必須要收費的,收費的標准是對應每次據出木塊的長度,比如說測試數據中 5 8 8,一開始,FJ需要在無限長的木板上鋸下長度 21 的木板(5+8+8=21),第二次鋸下長度為 5 的木板,第三次鋸下長度為 8 的木板,至此就可以將長度分別為 5 8 8 的木板找出


題目可以轉化為Huffman樹構造問題 :

給定 N planks of woods,

1.   在 N planks 中每次找出兩塊長度最短的木板,然后把它們合並,加入到集合A中,

2.  在集合中找出兩塊長度最短的木板,合並加入到集合A中,重復過程,直到集合A中只剩下一個元素

顯然,通過每次選取兩塊長度最短的木板,合並,最終必定可以合並出長度為 Sum(Li)的木板,並且可以保證總的耗費最少
*/
#include <iostream>
#include<algorithm>
#include<queue>
#include<stack>
#include<cmath>
#include<string.h>
#include<stdio.h>
#include<stdlib.h>
using namespace std;
int main()
{
    long long int sum;
    int i,n,t,a,b;
    while(~scanf("%d",&n))
    {
        priority_queue<int,vector<int>,greater<int> >q;
        for(i=0; i<n; i++)
        {
            scanf("%d",&t);
            q.push(t);
        }
        sum=0;
        if(q.size()==1)
        {
            a=q.top();
            sum+=a;
            q.pop();
        }
        while(q.size()>1)
        {
            a=q.top();
            q.pop();
            b=q.top();
            q.pop();
            t=a+b;
            sum+=t;
            q.push(t);
        }
        printf("%lld\n",sum);
    }
    return 0;
}

 


免責聲明!

本站轉載的文章為個人學習借鑒使用,本站對版權不負任何法律責任。如果侵犯了您的隱私權益,請聯系本站郵箱yoyou2525@163.com刪除。



 
粵ICP備18138465號   © 2018-2025 CODEPRJ.COM