hdu 5437 Alisha’s Party 優先隊列


Alisha’s Party

Time Limit: 1 Sec  

Memory Limit: 256 MB

題目連接

http://acm.hdu.edu.cn/contests/contest_showproblem.php?pid=1001&cid=621

Description

Princess Alisha invites her friends to come to her birthday party. Each of her friends will bring a gift of some value v, and all of them will come at a different time. Because the lobby is not large enough, Alisha can only let a few people in at a time. She decides to let the person whose gift has the highest value enter first.

Each time when Alisha opens the door, she can decide to let p people enter her castle. If there are less than p people in the lobby, then all of them would enter. And after all of her friends has arrived, Alisha will open the door again and this time every friend who has not entered yet would enter.

If there are two friends who bring gifts of the same value, then the one who comes first should enter first. Given a query n Please tell Alisha who the n−th person to enter her castle is.

Input

The first line of the input gives the number of test cases, T , where 1≤T≤15.

In each test case, the first line contains three numbers k,m and q separated by blanks. k is the number of her friends invited where 1≤k≤150,000. The door would open m times before all Alisha’s friends arrive where 0≤m≤k. Alisha will have q queries where 1≤q≤100.

The i−th of the following k lines gives a string Bi, which consists of no more than 200 English characters, and an integer vi, 1≤vi≤108, separated by a blank. Bi is the name of the i−th person coming to Alisha’s party and Bi brings a gift of value vi.

Each of the following m lines contains two integers t(1≤t≤k) and p(0≤p≤k) separated by a blank. The door will open right after the t−th person arrives, and Alisha will let p friends enter her castle.

The last line of each test case will contain q numbers n1,...,nq separated by a space, which means Alisha wants to know who are the n1−th,...,nq−th friends to enter her castle.

Note: there will be at most two test cases containing n>10000.

Output

For each test case, output the corresponding name of Alisha’s query, separated by a space.

Sample Input

1
5 2 3
Sorey 3
Rose 3
Maltran 3
Lailah 5
Mikleo 6
1 1
4 2
1 2 3

 

Sample Output

Sorey Lailah Rose

HINT

 

題意

 有一個人會開門,然后讓擁有禮物價值最高的人進來,然后問你第k個人進來的人是誰

題解:

優先隊列咯,模擬模擬就好了

代碼:

#include <iostream>
#include <cstring>
#include <cstdio>
#include <algorithm>
#include <cmath>
#include <vector>
#include <stack>
#include <map>
#include <set>
#include <queue>
#include <iomanip>
#include <string>
#include <ctime>
#include <list>
#include <bitset>
typedef unsigned char byte;
#define pb push_back
#define input_fast std::ios::sync_with_stdio(false);std::cin.tie(0)
#define local freopen("in.txt","r",stdin)
#define pi acos(-1)

using namespace std;
const int maxn = 150000 + 500;
typedef pair<int,int>dl;
struct node
{
    int val;
    int idx;
    friend bool operator < (const node & a,const node & b)
    {
        return a.val < b.val || (a.val == b.val && a.idx > b.idx);
    }    
    node(int val,int idx) : val(val) , idx(idx) {}
};

priority_queue<node>qq;
int k , m , q , Time[maxn];
int v[maxn];
char ks[maxn][400];
dl tt[maxn];
int id[maxn];

void initiation()
{
   scanf("%d%d%d",&k,&m,&q);
   for(int i = 1 ; i <= k ; ++ i) scanf("%s%d",ks[i],&v[i]);
   for(int i = 1 ; i <= m ; ++ i) scanf("%d%d",&tt[i].first,&tt[i].second);
   sort(tt + 1 , tt + 1 + m);
   for(int i = 1 ; i <= q; ++ i) scanf("%d",&id[i]);
}


void solve()
{
    int ptr = 1;
    int cot = 0;
    int T = 1;
    for(int i = 1 ; i <= k ; ++ i)
    {
        cot++;
        qq.push(node(v[i],i));
        while(ptr != m+1 && tt[ptr].first <= cot)
        {
            int cv = tt[ptr].second;
            while(cv && !qq.empty())
            {
                node ss = qq.top();qq.pop();
                Time[T++] = ss.idx;
                cv--;
            }
            ptr++;
        }
    }
    while(!qq.empty())
    {
        node ss = qq.top();qq.pop();
        Time[T++] = ss.idx;
    }
    printf("%s",ks[Time[id[1]]]);
    for(int i = 2 ; i <= q ; ++ i) printf(" %s",ks[Time[id[i]]]);
    printf("\n");
}


int main(int argc,char *argv[])
{
    int Case;
    scanf("%d",&Case);
    while(Case--)
    {
        initiation();
        solve();
    }
    return 0;
}

 


免責聲明!

本站轉載的文章為個人學習借鑒使用,本站對版權不負任何法律責任。如果侵犯了您的隱私權益,請聯系本站郵箱yoyou2525@163.com刪除。



 
粵ICP備18138465號   © 2018-2025 CODEPRJ.COM