交換機VLAN、 TRUNK 、VTP 配置


交換機VLANTRUNK VTP 配置

1. 配置 CISCO 二層交換機的IP 地址(catalyst 2950 為例)

SW1(config)#int vlan 1 //進入管理接口interface vlan 1

SW1(config-if)#ip address 11.1.1.2 255.255.255.0 //配置IP 地址

SW1(config-if)#no shutdown

SW1(config-if)#exit

SW1(config)#ip default-gateway 11.1.1.1 //配置網關,可通過show run 查

查看所配置的 IP 地址:

SW1#show int vlan 1

Vlan1 is up, line protocol is up

Hardware is CPU Interface, address is 0008.20ff.6400 (bia 0008.20ff.6400)

Internet address is 11.1.1.2/24

2.配置交換機的端口速度和雙工(Speed and Duplex)

SW1(config)#interface fa0/1

SW1(config-if)#speed {10 | 100 | auto} //10M/100M/自適應

SW1(config-if)#duplex {auto | full | half} //自適應/全雙工/半雙工

一般情況下,交換機兩端的端口速度和雙工要匹配,這樣通信質量才能得到保證,在相同廠家的產品

(比如說Cisco 的交換機互連)中端口協商不用配置一般不會有什么問題,可以通過show interface 查

看端口的速度和雙工。通常在不同廠家的產品中(比如說Cisco 和華為互連)如果通過查看發現端口速

度和雙工不匹配,可以通過手工配置來解決。如圖:

 

通過 show interface 查看端口的速度和雙工:

SW1#show interfaces fastEthernet 0/24

FastEthernet0/24 is up, line protocol is up (connected)

Hardware is Fast Ethernet, address is 0008.20ff.6418 (bia 0008.20ff.6418)

MTU 1500 bytes, BW 100000 Kbit, DLY 100 usec,

reliability 255/255, txload 1/255, rxload 1/255

Encapsulation ARPA, loopback not set

Keepalive set (10 sec)

Full-duplex, 100Mb/s, media type is 100BaseTX

input flow-control is unsupported output flow-control is unsupported

ARP type: ARPA, ARP Timeout 04:00:00

Last input 00:00:03, output 00:00:00, output hang never

注:CISCO 交換機端口默認值:Auto-duplex, Auto-speed, media type is 100BaseTX

Cisco 設備配置端口速度(speed)和雙工(duplex)命令:

SW1(config)#interface fastEthernet 0/24

SW1(config-if)#speed ?

10 Force 10 Mbps operation ----------------------------注:強制速度為10M

100 Force 100 Mbps operation---------------------------注:強制速度為100M

auto Enable AUTO speed configuration -----------------注:速度自動協議(默認值)

SW1(config-if)#duplex ?

auto Enable AUTO duplex configuration ----------------注:自動協商雙工

full Force full duplex operation ---------------------------注:強制為全雙工

half Force half-duplex operation --------------------------注:強制為半雙工

3.設置永久MAC 地址不過期

SW1(config)#mac-address-table static mac_addr {vlan vlan_id} [interface int1 [int2 ... int15]]

SW1(config)#mac-address-table static 1111.1111.a111 vlan 1 interface f0/1

配置后show mac-address-table 可以看到靜態添加的MAC 地址1111.1111.a111

SW1#show mac-address-table

Vlan Mac Address Type Ports

---- ----------- -------- -----

All 000f.72db.4ec0 STATIC CPU

1 1111.1111.a111 STATIC Fa0/1

4.管理MAC 地址表

SW1#show mac-address-table

Mac Address Table

-------------------------------------------

Vlan Mac Address Type Ports

---- ----------- -------- -----

All 000f.72db.4ec0 STATIC CPU

1 0000.0c3f.0b05 DYNAMIC Fa0/12

1 0030.94e6.391d DYNAMIC Fa0/11

1 00e0.b05a.5bfe DYNAMIC Fa0/10

1 1111.1111.a111 STATIC Fa0/1

5.設置交換機端口的訪問模式(三種) access /dynamic / trunk

SW1(config-if)#switchport mode ?

access Set trunking mode to ACCESS unconditionally

dynamic Set trunking mode to dynamically negotiate access or trunk mode

trunk Set trunking mode to TRUNK unconditionally

SW1(config)#int fastEthernet 0/1

SW1(config-if)#switchport mode access //設置FA0/1 為ACCESS 模式

SW1(config-if)#switchport mode trunk //設置FA0/1 為TRUNK 模式

SW1(config-if)#switchport mode dynamic auto //設置FA0/1 為自動直協商模式(默認)

交換機TRUNK 端口配置:

1)一般交換機與交換機相連接的端口要設置為trunk 模式

2 )如果是梳心交換機與非網管的交換機相連,梳心交換機端口設置為access 模式

如下圖:

 

配置 SW1:

SW1(config)#int f0/24

SW1(config-if)#no shutdown

SW1(config-if)#switchport mode trunk //設置FA0/24 為TRUNK 模式

配置 SW2:

SW2(config)#int f0/24

SW2(config-if)#no shutdown

SW2(config-if)#switchport mode trunk //設置FA0/24 為TRUNK 模式

驗證 TRUNK 命令:

Show interface trunk

Show interface f0/24 switchport

SW1#sho run int f0/24

interface FastEthernet0/24

switchport mode trunk

SW1#show int trunk

Port Mode Encapsulation Status Native vlan

Fa0/24 on 802.1q trunking 1

SW1#show int f0/24 switchport

Name: Fa0/24

Switchport: Enabled

Administrative Mode: trunk

Operational Mode: trunk

Administrative Trunking Encapsulation: dot1q

Operational Trunking Encapsulation: dot1q

Negotiation of Trunking: On

Access Mode VLAN: 1 (default)

Trunking Native Mode VLAN: 1 (default)

Voice VLAN: none

Administrative private-vlan host-association: none

Administrative private-vlan mapping: none

Administrative private-vlan trunk native VLAN: none

Administrative private-vlan trunk encapsulation: dot1q

Administrative private-vlan trunk normal VLANs: none

Administrative private-vlan trunk private VLANs: none

Operational private-vlan: none

Trunking VLANs Enabled: ALL

Pruning VLANs Enabled: 2-1001

Capture Mode Disabled

Capture VLANs Allowed: ALL

Protected: false

Appliance trust: none

SW1#

SW2:

SW2#sho run int f0/24

interface FastEthernet0/24

switchport mode trunk

end

SW2#show int trunk

Port Mode Encapsulation Status Native vlan

Fa0/24 on 802.1q trunking 1

6.配置VLAN

1).創建VLAN

SW1(config)#vlan 2 //創建VLAN2

SW1(config)#name VLAN2 //命名為VLAN2,默認為vlan002,命名是可選命令

2).將端口加入VLAN

SW1(config-if)#switchport mode access //設配端口為access 模式

SW1(config-if)#switchport access vlan 2 //把端口加到vlan2

3).檢查的命令

Switch#show vlan

例子:

創建 VLAN2 命令為widom ,

創建VLAN3 命令為market

把端口F0/4 加入VLAN2

SW1#config t

SW1(config)#vlan 2

SW1(config-vlan)#name wisdom

SW1(config-vlan)#exit

SW1(config)#vlan 3

SW1(config-vlan)#name market

SW1(config-vlan)#exit

SW1(config)#int fas0/4

SW1(config-if)#switchport mode access

SW1(config-if)#switchport access vlan 2

可以同時把多個端口加入到相應VLAN

SW1(config)#interface range fastEthernet 0/10 – 15 //可以同時把多個端口加入到一個VLAN 里

SW1(config-if-range)#switchport mode access

SW1(config-if-range)#switchport access vlan 3 //把端口10-15 都加入到VLAN3 里

SW1#show vlan //檢查VLAN 信息

VLAN Name Status Ports

---- -------------------------------- --------- -------------------------------

1 default active Fa0/1, Fa0/5, Fa0/6, Fa0/7

Fa0/8, Fa0/9, Fa0/16, Fa0/17

Fa0/18, Fa0/19, Fa0/20, Fa0/21

Fa0/22, Fa0/23, Fa0/24

2 wisdom active Fa0/4

3 market active Fa0/10, Fa0/11, Fa0/12

Fa0/13, Fa0/14, Fa0/15

SW1#

7.配置VTP----VTP 技術使得在大型的網絡里布置多個VLAN 變得簡單.

VTP 的配置步驟:

1、配置Trunk (交換機和交換機相連的端口要設置為TRUNK)

2、配置VTP DOMAIN

3、配置VTP MODE

4、配置VLAN

5、將端口加入VLAN

6、檢查

Switch#show interface xx/xx switchport //查看相應該接口的trunk 狀態

Switch#show vtp status  //查看vtp 狀態

Switch#show vlan //查看VLAN

 

 

配置 SW1:

SW1#configure terminal

SW1(config)#interface fastEthernet 0/24

SW1(config-if)#switchport mode trunk

SW1(config-if)#no shutdown

SW1(config-if)#exit

SW1(config)#vtp domain wisdom

Domain name already set to wisdom.

SW1(config)#vtp mode server

Device mode already VTP SERVER.

SW1(config)#vtp password cisco

Setting device VLAN database password to cisco

SW1(config)#vtp pruning //配置VTP 的修剪,只要在SERVER 端配置就行.

Pruning switched on

SW1#sho vtp status

VTP Version : 2

Configuration Revision : 1

Maximum VLANs supported locally : 64

Number of existing VLANs : 5

VTP Operating Mode : Server

VTP Domain Name : wisdom

VTP Pruning Mode : Enabled

VTP V2 Mode : Disabled

VTP Traps Generation : Disabled

MD5 digest : 0xE8 0x5A 0x7D 0xB1 0x0E 0xBC 0xEB 0x1F

Configuration last modified by 11.1.1.2 at 3-1-93 02:56:31

Local updater ID is 11.1.1.2 on interface Vl1 (lowest numbered VLAN interface found)

創建 VLAN2 VLAN3 VLAN4 VLAN5

SW1(config)#vlan 2

SW1(config-vlan)#vlan 3

SW1(config-vlan)#vlan 4

SW1(config-vlan)#vlan 5

SW1(config-vlan)#

在 SW1 上創建VLAN 后查看修訂版本:

SW1#show vtp status

VTP Version : 2

Configuration Revision : 5

Maximum VLANs supported locally : 128

Number of existing VLANs : 9

VTP Operating Mode : Server

VTP Domain Name : wisdom

VTP Pruning Mode : Enabled

VTP V2 Mode : Disabled

VTP Traps Generation : Disabled

MD5 digest : 0x9C 0x64 0xD6 0x44 0x5E 0x54 0x9E 0xFC

Configuration last modified by 11.1.1.2 at 3-1-93 02:59:04

Local updater ID is 11.1.1.2 on interface Vl1 (lowest numbered VLAN interface found)

在交換機 SW1 上檢查已創建的VLAN

SW1#sho vlan

VLAN Name Status Ports

---- -------------------------------- --------- -------------------------------

1 default active Fa0/1, Fa0/5, Fa0/6, Fa0/7

Fa0/8, Fa0/9, Fa0/16, Fa0/17

Fa0/18, Fa0/19, Fa0/20, Fa0/21

Fa0/22, Fa0/23, Fa0/24

2 VLAN0002 active

3 VLAN0003 active

4 VLAN0004 active

5 VLAN0005 active

檢查 trunk 端口:

SW1#show interfaces fastEthernet 0/24 switchport

Name: Fa0/24

Switchport: Enabled

Administrative Mode: trunk

Operational Mode: trunk

Administrative Trunking Encapsulation: dot1q

Operational Trunking Encapsulation: dot1q

Negotiation of Trunking: On

Access Mode VLAN: 1 (default)

Trunking Native Mode VLAN: 1 (default)

Voice VLAN: none

Administrative private-vlan host-association: none

Administrative private-vlan mapping: none

Administrative private-vlan trunk native VLAN: none

Administrative private-vlan trunk encapsulation: dot1q

Administrative private-vlan trunk normal VLANs: none

Administrative private-vlan trunk private VLANs: none

Operational private-vlan: none

Trunking VLANs Enabled: ALL

Pruning VLANs Enabled: 2-1001

Capture Mode Disabled

Capture VLANs Allowed: ALL

Protected: false

Appliance trust: none

配置 SW2:

Switch#

Switch#config t

Enter configuration commands, one per line. End with CNTL/Z.

SW2(config)#hostname SW2

SW2(config)#int fastEthernet 0/24

SW2(config-if)#switchport mode trunk

SW2(config-if)#exit

SW2(config)#vtp domain wisdom

Changing VTP domain name from test to wisdom

SW2(config)#vtp mode client

Setting device to VTP CLIENT mode.

SW2(config)#vtp password cisco

Setting device VLAN database password to cisco

SW2(config)#

查看 F0/24 trunk 狀態:

SW2#show interfaces fastEthernet 0/24 switchport

Name: Fa0/24

Switchport: Enabled

Administrative Mode: trunk

Operational Mode: trunk

Administrative Trunking Encapsulation: dot1q

Operational Trunking Encapsulation: dot1q

Negotiation of Trunking: On

Access Mode VLAN: 1 (default)

Trunking Native Mode VLAN: 1 (default)

Voice VLAN: none

Administrative private-vlan host-association: none

Administrative private-vlan mapping: none

Administrative private-vlan trunk native VLAN: none

Administrative private-vlan trunk encapsulation: dot1q

Administrative private-vlan trunk normal VLANs: none

Administrative private-vlan trunk private VLANs: none

Operational private-vlan: none

Trunking VLANs Enabled: ALL

Pruning VLANs Enabled: 2-1001

Capture Mode Disabled

Capture VLANs Allowed: ALL

Protected: false

Appliance trust: none

查看 VTP 狀態:

SW2#show vtp status

VTP Version : 2

Configuration Revision : 5

Maximum VLANs supported locally : 128

Number of existing VLANs : 9

VTP Operating Mode : Client

VTP Domain Name : wisdom

VTP Pruning Mode : Enabled

VTP V2 Mode : Disabled

VTP Traps Generation : Disabled

MD5 digest : 0x9C 0x64 0xD6 0x44 0x5E 0x54 0x9E 0xFC

Configuration last modified by 11.1.1.2 at 3-1-93 02:59:04

----------此處可以看到SW2 的VLAN 信息是從SW1-11.1.1.2 同步過來的

SW2#show vlan

VLAN Name Status Ports

---- -------------------------------- --------- -------------------------------

1 default active Fa0/2, Fa0/3, Fa0/4, Fa0/5

Fa0/6, Fa0/7, Fa0/8, Fa0/9

Fa0/10, Fa0/11, Fa0/12, Fa0/13

Fa0/14, Fa0/15, Fa0/16, Fa0/17

Fa0/18, Fa0/19, Fa0/20, Fa0/21

Fa0/22, Fa0/23, Fa0/24

2 VLAN0002 active

3 VLAN0003 active

4 VLAN0004 active

5 VLAN0005 active

實驗結果:

SW2 不用配置VLAN,已同步了SW1 的VLAN 信息.實驗成功

SW2 同步VTP SERVER 的VLAN 后,接下來的操作就是安要求把相應的端口加入到相應的VLAN


免責聲明!

本站轉載的文章為個人學習借鑒使用,本站對版權不負任何法律責任。如果侵犯了您的隱私權益,請聯系本站郵箱yoyou2525@163.com刪除。



 
粵ICP備18138465號   © 2018-2025 CODEPRJ.COM