POJ 3463 Sightseeing (最短路和次短路)


Sightseeing
Time Limit: 2000MS   Memory Limit: 65536K
Total Submissions: 6240   Accepted: 2197

Description

Tour operator Your Personal Holiday organises guided bus trips across the Benelux. Every day the bus moves from one city S to another city F. On this way, the tourists in the bus can see the sights alongside the route travelled. Moreover, the bus makes a number of stops (zero or more) at some beautiful cities, where the tourists get out to see the local sights.

Different groups of tourists may have different preferences for the sights they want to see, and thus for the route to be taken from S to F. Therefore, Your Personal Holiday wants to offer its clients a choice from many different routes. As hotels have been booked in advance, the starting city S and the final city F, though, are fixed. Two routes from S to F are considered different if there is at least one road from a city A to a city B which is part of one route, but not of the other route.

There is a restriction on the routes that the tourists may choose from. To leave enough time for the sightseeing at the stops (and to avoid using too much fuel), the bus has to take a short route from S to F. It has to be either a route with minimal distance, or a route which is one distance unit longer than the minimal distance. Indeed, by allowing routes that are one distance unit longer, the tourists may have more choice than by restricting them to exactly the minimal routes. This enhances the impression of a personal holiday.

For example, for the above road map, there are two minimal routes from S = 1 to F = 5: 1 → 2 → 5 and 1 → 3 → 5, both of length 6. There is one route that is one distance unit longer: 1 → 3 → 4 → 5, of length 7.

Now, given a (partial) road map of the Benelux and two cities S and F, tour operator Your Personal Holiday likes to know how many different routes it can offer to its clients, under the above restriction on the route length.

Input

The first line of the input file contains a single number: the number of test cases to follow. Each test case has the following format:

  • One line with two integers N and M, separated by a single space, with 2 ≤ N ≤ 1,000 and 1 ≤ M ≤ 10, 000: the number of cities and the number of roads in the road map.

  • M lines, each with three integers AB and L, separated by single spaces, with 1 ≤ AB ≤ NA ≠ B and 1 ≤ L ≤ 1,000, describing a road from city A to city B with length L.

    The roads are unidirectional. Hence, if there is a road from A to B, then there is not necessarily also a road from B to A. There may be different roads from a city A to a city B.

  • One line with two integers S and F, separated by a single space, with 1 ≤ SF ≤ N and S ≠ F: the starting city and the final city of the route.

    There will be at least one route from S to F.

Output

For every test case in the input file, the output should contain a single number, on a single line: the number of routes of minimal length or one distance unit longer. Test cases are such, that this number is at most 109 = 1,000,000,000.

Sample Input

2
5 8
1 2 3
1 3 2
1 4 5
2 3 1
2 5 3
3 4 2
3 5 4
4 5 3
1 5
5 6
2 3 1
3 2 1
3 1 10
4 5 2
5 2 7
5 2 7
4 1

Sample Output

3
2

Hint

The first test case above corresponds to the picture in the problem description.

Source

 

 

題意:旅行團每天固定的從S地出發到達T地,為了省油要求盡量走最短路徑或比最短路徑長1單位距離的路徑,求滿足條件的路徑條數

算法:最短路和次短路。Dijkstra算法。采用鄰接表建圖。

總結:不要用鄰接矩陣。因為有重邊。

 

dis[x][2]:dis[x][0]表示起點到x的最短路、dis[x][1]表示起點到x的次短路;

arr[x][2]:arr[x][0]表示起點到x的最短路條數、arr[x][1]表示起點到x的次短路的條數;

vis[x][2]對應於x和0、1功能為記錄該點是否被訪問!

     那么如何更新最小和次小路呢?顯然我們容易想到下面的方法:

      1.if(x<最小)更新最小,次小;
      2.else if(x==最小)更新方法數;
      3.else if(x<次小)更新次小;
      4.else if(x==次小)更新方法數;

     最后說說dijkstra的循環部分、這也是本題的關鍵。為什么我們要循環2*nnum-1次?顯然這道題中我們每一條邊都需要考慮、這不是在求最短的一條,說白了是讓你求出所有的可能組合,那么我們勢必對每一種情況都需要遍歷一次,雖然中間有重復。最短路里已知[start][0]已被標記為訪問過,那么就只有nnum-1次遍歷了,而次短路我們則需要遍歷nnum次,這樣兩者加起來就為2*nnum-1次。這與我們平時使用優先隊列+heap是一樣的。只是更加細化了而已。

 

#include<iostream>
#include<cstdio>
#include<cstring>

using namespace std;

const int INF=0x3f3f3f3f;
const int VM=1010;
const int EM=10010;

struct Edge{
    int to,nxt;
    int cap;
}edge[EM<<1];

int vis[VM][2],dis[VM][2];  // dis[i][0]:到點i的最短路   dis[i][1]:到點j的次短路
int head[VM],count[VM][2];  // count[i][0]:到點i的最短路的路數   len[i][1]:到點j的次短路的路數
int n,m,cnt;

void addedge(int cu,int cv,int cw){
    edge[cnt].to=cv;
    edge[cnt].cap=cw;
    edge[cnt].nxt=head[cu];
    head[cu]=cnt++;
}

void Dijkstra(int src,int des){
    memset(vis,0,sizeof(vis));
    memset(count,0,sizeof(count));
    int i=0;
    for(i=1;i<=n;i++){
        dis[i][0]=INF;
        dis[i][1]=INF;
    }
    dis[src][0]=0;
    count[src][0]=1;
    int j,k,tmp,flag;
    for(i=1;i<=2*n-1;i++){
        tmp=INF;    // 找新的最短路和次短路
        for(j=1;j<=n;j++)
            if(!vis[j][0] && tmp>dis[j][0]){
                k=j;
                flag=0;
                tmp=dis[j][0];
            }else if(!vis[j][1] && tmp>dis[j][1]){
                k=j;
                flag=1;
                tmp=dis[j][1];
            }
        if(tmp==INF)    // 如果最短路和次短路都不存在,則退出for循環
            break;
        vis[k][flag]=1;
        for(j=head[k];j!=-1;j=edge[j].nxt){ // 更新和點k相連的邊
            int v=edge[j].to;
            if(dis[v][0]>tmp+edge[j].cap){  // 比最短路短
                dis[v][1]=dis[v][0];
                count[v][1]=count[v][0];
                dis[v][0]=tmp+edge[j].cap;
                count[v][0]=count[k][flag];
            }else if(dis[v][0]==tmp+edge[j].cap){   // 等於最短路
                count[v][0]+=count[k][flag];
            }else if(dis[v][1]>tmp+edge[j].cap){    // 比次短路短
                dis[v][1]=tmp+edge[j].cap;
                count[v][1]=count[k][flag];
            }else if(dis[v][1]==tmp+edge[j].cap){   // 等於次短路
                count[v][1]+=count[k][flag];
            }
        }
    }
    if(dis[des][1]==dis[des][0]+1)
        count[des][0]+=count[des][1];
    printf("%d\n",count[des][0]);
}

int main(){

    //freopen("input.txt","r",stdin);

    int t;
    scanf("%d",&t);
    while(t--){
        cnt=0;
        memset(head,-1,sizeof(head));
        scanf("%d%d",&n,&m);
        int u,v,w;
        while(m--){
            scanf("%d%d%d",&u,&v,&w);
            addedge(u,v,w);
        }
        int src,des;
        scanf("%d%d",&src,&des);
        Dijkstra(src,des);
    }
    return 0;
}

 


免責聲明!

本站轉載的文章為個人學習借鑒使用,本站對版權不負任何法律責任。如果侵犯了您的隱私權益,請聯系本站郵箱yoyou2525@163.com刪除。



 
粵ICP備18138465號   © 2018-2025 CODEPRJ.COM