[解題報告]HDU 1004 Let the Balloon Rise


Let the Balloon Rise

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 50554    Accepted Submission(s): 18117


Problem Description
Contest time again! How excited it is to see balloons floating around. But to tell you a secret, the judges' favorite time is guessing the most popular problem. When the contest is over, they will count the balloons of each color and find the result.

This year, they decide to leave this lovely job to you. 
 

 

Input
Input contains multiple test cases. Each test case starts with a number N (0 < N <= 1000) -- the total number of balloons distributed. The next N lines contain one color each. The color of a balloon is a string of up to 15 lower-case letters.

A test case with N = 0 terminates the input and this test case is not to be processed.
 

 

Output
For each case, print the color of balloon for the most popular problem on a single line. It is guaranteed that there is a unique solution for each test case.
 

 

Sample Input
5 green red blue red red 3 pink orange pink 0
 

 

Sample Output
red pink
 

 

Author
WU, Jiazhi
 

 

Source
 

 

Recommend
JGShining
 
 
 
 
 
 
 
 
 
用color[1000][16]來存儲顏色信息
用num[1000]來統計每個顏色出現的次數
先輸入一個顏色,從第二個顏色的輸入開始,每輸入一個,都要和之前輸入的所有顏色進行比較,若是一樣,則在數組對應位置上+1,
3
color[0] pink    
color[1] pink num[1]=2
color[2] blue num[2]=1
然后在num[1000]中查找最大數,輸出其下標,找到對應的顏色輸出
 
#include <stdio.h>
#include <string.h>
int main()
{
    int n,i,j,num[1000];
    int max=0,t=0;
    char color[1000][16];
    while(scanf("%d",&n)!=EOF)
    {
        if(n)
        {
            num[0]=0;
            scanf("%s",color[0]);
            for(i=1;i<n;i++)
            {
                num[i]=0;
                scanf("%s",color[i]);
                for(j=0;j<i-1;j++)
                    if(strcmp(color[i],color[j])==0) num[i]+=1;
            }
            max=0;
            t=0;
            for(i=1;i<n;i++)
               if(max<num[i]) 
               {
                   max=num[i];
                   t=i;}
            printf("%s\n",color[t]);
        }
    }
}

 


免責聲明!

本站轉載的文章為個人學習借鑒使用,本站對版權不負任何法律責任。如果侵犯了您的隱私權益,請聯系本站郵箱yoyou2525@163.com刪除。



 
粵ICP備18138465號   © 2018-2025 CODEPRJ.COM