HDU 1150 Machine Schedule(最小點覆蓋)


Machine Schedule

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 3444    Accepted Submission(s): 1669


Problem Description
As we all know, machine scheduling is a very classical problem in computer science and has been studied for a very long history. Scheduling problems differ widely in the nature of the constraints that must be satisfied and the type of schedule desired. Here we consider a 2-machine scheduling problem.

There are two machines A and B. Machine A has n kinds of working modes, which is called mode_0, mode_1, …, mode_n-1, likewise machine B has m kinds of working modes, mode_0, mode_1, … , mode_m-1. At the beginning they are both work at mode_0.

For k jobs given, each of them can be processed in either one of the two machines in particular mode. For example, job 0 can either be processed in machine A at mode_3 or in machine B at mode_4, job 1 can either be processed in machine A at mode_2 or in machine B at mode_4, and so on. Thus, for job i, the constraint can be represent as a triple (i, x, y), which means it can be processed either in machine A at mode_x, or in machine B at mode_y.

Obviously, to accomplish all the jobs, we need to change the machine's working mode from time to time, but unfortunately, the machine's working mode can only be changed by restarting it manually. By changing the sequence of the jobs and assigning each job to a suitable machine, please write a program to minimize the times of restarting machines.
 

 

Input
The input file for this program consists of several configurations. The first line of one configuration contains three positive integers: n, m (n, m < 100) and k (k < 1000). The following k lines give the constrains of the k jobs, each line is a triple: i, x, y.

The input will be terminated by a line containing a single zero.
 

 

Output
The output should be one integer per line, which means the minimal times of restarting machine.
 

 

Sample Input
5 5 10 0 1 1 1 1 2 2 1 3 3 1 4 4 2 1 5 2 2 6 2 3 7 2 4 8 3 3 9 4 3 0
 

 

Sample Output
3
 

 

Source
 

 

Recommend
Ignatius.L
 
 
題目大意;有兩台機器A和B以及N個需要運行的任務。每台機器有M種不同的模式,而每個任務都恰好在一台機器上運行。 如果它在機器A上運行,則機器A需要設置為模式xi,如果它在機器B上運行,則機器A需要設置為模式yi。 每台機器上的任務可以按照任意順序執行,但是每台機器每轉換一次模式需要重啟一次。請合理為每個任務安排一台機器並合理安排順序,使得機器重啟次數盡量少。

二分圖的最小頂點覆蓋數=最大匹配數

本題就是求最小頂點覆蓋數的。

 

每個任務建立一條邊。

最小點覆蓋就是求最少的點可以連接到所有的邊。本題就是最小點覆蓋=最大二分匹配數。

 

注意一點就是:題目說初始狀態為0,所以如果一個任務有一點為0的邊不要添加。因為不需要代價

 

 

/*
HDU 1150
題目大意;有兩台機器A和B以及N個需要運行的任務。每台機器有M種不同的模式,而每個任務都恰好在一台機器上運行。如果它在機器A上運行,則機器A需要設置為模式xi,如果它在機器B上運行,則機器A需要設置為模式yi。每台機器上的任務可以按照任意順序執行,但是每台機器每轉換一次模式需要重啟一次。請合理為每個任務安排一台機器並合理安排順序,使得機器重啟次數盡量少。
二分圖的最小頂點覆蓋數=最大匹配數

本題就是求最小頂點覆蓋數的。

相當於是最小的點消滅掉所有的邊,所以是最小頂點覆蓋

*/

#include<stdio.h>
#include<string.h>
#include<algorithm>
#include<iostream>
using namespace std;


/* **************************************************************************
//二分圖匹配(匈牙利算法的DFS實現)
//初始化:g[][]兩邊頂點的划分情況
//建立g[i][j]表示i->j的有向邊就可以了,是左邊向右邊的匹配
//g沒有邊相連則初始化為0
//uN是匹配左邊的頂點數,vN是匹配右邊的頂點數
//調用:res=hungary();輸出最大匹配數
//優點:適用於稠密圖,DFS找增廣路,實現簡潔易於理解
//時間復雜度:O(VE)
//***************************************************************************/
//頂點編號從0開始的
const int MAXN=110;
int uN,vN;//u,v數目
int g[MAXN][MAXN];
int linker[MAXN];
bool used[MAXN];
bool dfs(int u)//從左邊開始找增廣路徑
{
    int v;
    for(v=0;v<vN;v++)//這個頂點編號從0開始,若要從1開始需要修改
      if(g[u][v]&&!used[v])
      {
          used[v]=true;
          if(linker[v]==-1||dfs(linker[v]))
          {//找增廣路,反向
              linker[v]=u;
              return true;
          }
      }
    return false;//這個不要忘了,經常忘記這句
}
int hungary()
{
    int res=0;
    int u;
    memset(linker,-1,sizeof(linker));
    for(u=0;u<uN;u++)
    {
        memset(used,0,sizeof(used));
        if(dfs(u)) res++;
    }
    return res;
}
//******************************************************************************/
int main()
{
    int k;
    int i,u,v;
    while(scanf("%d",&uN),uN)
    {
        scanf("%d%d",&vN,&k);
        memset(g,0,sizeof(g));
        while(k--)
        {
            scanf("%d%d%d",&i,&u,&v);
            if(u>0&&v>0)g[u][v]=1;//初始狀態為0,一開始0的邊不要加
        }
        printf("%d\n",hungary());
    }
    return 0;
}

 

 

 


免責聲明!

本站轉載的文章為個人學習借鑒使用,本站對版權不負任何法律責任。如果侵犯了您的隱私權益,請聯系本站郵箱yoyou2525@163.com刪除。



 
粵ICP備18138465號   © 2018-2025 CODEPRJ.COM