本文主要針對macOS Mojave(10.14.4)版本的優化,原生系統中會有很多后台聯網程序,大部分都有可能透漏隱私(也適用與用無線網卡上網的朋友,可以節省流量哦),所以我選擇重命名這些程序,帶來的后果是部分功能不能正常使用,會出現程序崩潰的情況,如果有朋友參考我的操作,請慎重,本文僅供參考。一切操作都需要進入recovery os使用csrutil disable關閉SIP后才能執行,配置好一定要使用csrutil enable重新開啟SIP。
/usr/libexec/rapportd.old (如不禁用,會一直開啟) /usr/sbin/mDNSResponderHelper.old /Library/Preferences/SystemConfiguration/preferences.plist.old /Library/SystemMigration/History/Migration-17A36F34-1359-403C-957F-3F1857221153/QuarantineRoot/usr/libexec/rapportd.old /Library/SystemMigration/History/Migration-17A36F34-1359-403C-957F-3F1857221153/QuarantineRoot/usr/libexec/AirPlayXPCHelper.old /System/Library/PrivateFrameworks/ApplePushService.framework/apsd.old /System/Library/PrivateFrameworks/GeoServices.framework/Versions/A/XPCServices/com.apple.geod.xpc/Contents/MacOS/com.apple.geod.old /System/Library/PrivateFrameworks/AuthKit.framework/Versions/A/Support/akd.old /System/Library/PrivateFrameworks/CloudKitDaemon.framework/Support/cloudd.old (雲服務,如不禁用,會一直開啟) /System/Library/PrivateFrameworks/IMFoundation.framework/XPCServices/IMRemoteURLConnectionAgent.xpc/Contents/MacOS/IMRemoteURLConnectionAgent.old /System/Library/PrivateFrameworks/CommerceKit.framework/Versions/A/Resources/commerced.old /System/Library/PrivateFrameworks/CommerceKit.framework/Versions/A/Resources/commerce.old /System/Library/PrivateFrameworks/SyncedDefaults.framework/Support/syncdefaultsd.old /System/Library/Frameworks/WebKit.framework/Versions/A/XPCServices/com.apple.WebKit.Networking.xpc/Contents/MacOS/com.apple.WebKit.Networking.old(safari崩潰) /System/Library/Frameworks/WebKit.framework/Versions/A/XPCServices/com.apple.WebKit.WebContent.xpc/Contents/MacOS/com.apple.WebKit.WebContent.old(safari崩潰)
查看網絡連接情況
while true; time=`date "+%Y-%m-%d %H:%M:%S"`;do lsof -nP -iTCP;echo '---------------------'$time'--------------------------'; sleep 2; done
安裝Brew
/usr/bin/ruby -e "$(curl -fsSL https://raw.githubusercontent.com/Homebrew/install/master/install)"
禁用啟動項
launchctl unload -w /System/Library/LaunchDaemons/com.apple.mobileassetd.plist launchctl unload -w /System/Library/LaunchDaemons/com.apple.ifdreader.plist launchctl unload -w /System/Library/LaunchDaemons/com.apple.analyticsd.plist launchctl unload -w /System/Library/LaunchDaemons/com.apple.MobileFileIntegrity.plist launchctl unload -w /System/Library/LaunchDaemons/com.apple.mobile.keybagd.plist
launchctl unload -w /System/Library/LaunchDaemons/com.apple.icloud.findmydeviced.plist launchctl unload -w /System/Library/LaunchDaemons/com.apple.locationd.plist
禁用Mac系統的Spotlight的方法及恢復方法:
禁用方法:打開終端,在終端中輸入如下內容:
sudo launchctl unload -w /System/Library/LaunchDaemons/com.apple.metadata.mds.plist
恢復方法,打開終端,在終端中輸入:
sudo launchctl load -w /System/Library/LaunchDaemons/com.apple.metadata.mds.plist
然后重啟就可以了 ====================
刪除 spotlight 圖標,在終端輸入:
1、cd /System/Library/CoreServices/
2、sudo mv Search.bundle/ Search2.bundle/
然后在活動監視器退出 SystemUIServer 進程.
恢復 spotlight 圖標到菜單欄的方法,在終端輸入:
1、cd /System/Library/CoreServices/
2、sudo mv Search2.bundle/ Search.bundle/
然后在活動監視器退出 SystemUIServer 進程.