7-42 圆形体体积计算器 (20分)
本题要求实现一个常用圆形体体积的计算器。计算公式如下:
- 球体体积 V=34πr3,其中r是球体半径。
- 圆柱体体积 V=πr2h,其中r是底圆半径,h是高。
- 圆锥体体积 V=31πr2h,其中r是底圆半径,h是高。
输入格式:
在每次计算之前,要求输出如下界面:
1-Ball 2-Cylinder 3-Cone other-Exit Please enter your command:
然后从标准输入读进一个整数指令。
输出格式:
如果读入的指令是1或2或3,则执行相应的体积计算;如果是其他整数,则程序结束运行。
- 当输入为1时,在计算球体体积之前,打印
Please enter the radius:
,然后读入球体半径,完成计算; - 当输入为2时,在计算圆柱体体积之前,打印
Please enter the radius and the height:
,然后读入底圆半径和高,完成计算; - 当输入为3时,在计算圆锥体体积之前,打印
Please enter the radius and the height:
,然后读入底圆半径和高,完成计算。
计算结果在一行内输出,保留小数点后两位。
输入样例:
1
2
3
2.4 3
0
输出样例:
1-Ball
2-Cylinder
3-Cone
other-Exit
Please enter your command:
Please enter the radius:
33.51
1-Ball
2-Cylinder
3-Cone
other-Exit
Please enter your command:
Please enter the radius and the height:
18.10
1-Ball
2-Cylinder
3-Cone
other-Exit
Please enter your command:
#include<stdio.h>
#include<math.h>
void start()
{
printf("1-Ball\n");
printf("2-Cylinder\n");
printf("3-Cone\n");
printf("other-Exit\n");
printf("Please enter your command:\n");
}
int main()
{
int n;
start();
double pi =atan(1)*4;
double result;
double radius;
double height;
while(scanf("%d",&n)!=EOF)
{
switch(n)
{
case 1:printf("Please enter the radius:\n");
scanf("%lf",&radius);
result=4/3.0*pi*pow(radius,3);
printf("%.2f\n",result);
break;
case 2:printf("Please enter the radius and the height:\n");
scanf("%lf %lf",&radius,&height);
result=height*pi*pow(radius,2);
printf("%.2f\n",result);
break;
case 3:printf("Please enter the radius and the height:\n");
scanf("%lf %lf",&radius,&height);
result=1/3.0*height*pi*pow(radius,2);
printf("%.2f\n",result);
break;
default:
return 0;
}
start();
}
return 0;
}