Android Studio V4 V7 包冲突的问题


最近被包冲突的问题搞奔溃了,特别是V4,V7

V4和V7包冲突的解决方式就是!版本要一致!!

比如我的一个项目中应用本来是这样引用包的

    compile 'com.android.support:support-v4:25.1.1
compile 'com.android.support:appcompat-v7:26.0.0-alpha1'
compile 'com.android.support:recyclerview-v7:+'


编译的时候就报:

Error:Execution failed for task ':app:transformClassesWithDexForBaiduRelease'.
> com.android.build.api.transform.TransformException: com.android.ide.common.process.ProcessException: java.util.concurrent.ExecutionException: com.android.dex.DexException: Multiple dex files define Landroid/support/v4/content/res/TypedArrayUtils;

 

然后就上网一通百度,比如

Android Studio(Gradle)解决库依赖冲突问题

http://www.mobibrw.com/2016/3777


然后在导出的依赖包的结构中找各种可能重复引用的可能,各种exclude,就是不行。
后来就把版本改成一样的,就好了。。。

    compile 'com.android.support:support-v4:25.1.1’
compile 'com.android.support:appcompat-v7:25.1.1'

compile 'com.android.support:recyclerview-v7:25.1.1'



免责声明!

本站转载的文章为个人学习借鉴使用,本站对版权不负任何法律责任。如果侵犯了您的隐私权益,请联系本站邮箱yoyou2525@163.com删除。



 
粤ICP备18138465号  © 2018-2020 CODEPRJ.COM